发表文章

[Python] [11.0] odoo v11 开发人员模式安装错误 < No module named packages > [11.0] odoo v11 developer mode installation error < No module named packages >[odoo]

vimit 2017-10-9 51

我有这个 bug, 我已经安装了所有的 python 软件包
bug1

bug2

原文:

i had this bug , i have all python packages installed
bug1

bug2

相关推荐
最新评论 (12)
totalard 2017-10-9
1

我得到了相同的

原文:

I got the same

yenthe666 2017-10-9
2

您好@vimit,

你能提供更多的信息吗?
这是社区版的吗?配置文件的外观如何?你有定制任何东西吗?

关于,
Yenthe

原文:

Hi @vimit,

Can you give more information please?
Is this on a community version? How does your config file look? Did you customize anything?

Regards,
Yenthe

gdgellatly 2017-10-9
3
原文:
yenthe666 2017-10-9
4

哦好捕获@gdgellatly
@sle-odoo我想你的问题已经回答了-看起来2.7 不会再在盒子里工作了。

原文:

Ohh good catch @gdgellatly.
@sle-odoo I guess your question is already answered - it looks like 2.7 won't work out of the box anymore.

vimit 2017-10-9
5

我使用的社区版本, 我没有改变任何东西在配置文件
我变成了 python 3, 我得到这个消息
bug3

原文:

I'm using community version, and i didn't change any thing in config file
I changed to python 3 and i get this message
bug3

gdgellatly 2017-10-9
6
原文:
yenthe666 2017-10-9
7

@vimit您具有 3.4.3 安装 (和 2.7 ) 的版本。这不是因为您有 python 3.4.3 安装了 Odoo 将自动使用 python 3.4.3 。在这种情况下, 您使用的是 V2。

原文:

@vimit you have version 3.4.3 installed (and 2.7). It is not because you have Python 3.4.3 installed that Odoo will automatically use Python 3.4.3. In this case you're using V2.

gdgellatly 2017-10-9
8
原文:
vimit 2017-10-9
9

与 python 3.5 相同
PYTHONPATH 在我的系统中有问题吗?

原文:

the same with python 3.5
is it problem with PYTHONPATH in my system ?

Derter 2017-10-9
10

我的错误与 OP 相同。我已经安装了 python 3.5 除了的 python 2.7 环境。它的 a VS, 它对 python 2.7 有依赖性。我怎样才能使它工作?谢谢你的建议。

bildschirmfoto 2017-10-06 um 15 55 23

编辑:
已尝试在不成功的情况下用 pip 重新安装3.5 版的请求。
已尝试用 pip 重新安装 urllib3 和工具版本 3.5, 但不成功。

原文:

I have the same error as OP. I have installed python 3.5 ontop of my python 2.7 environment. Its a VS and it has dependencies on python 2.7. How can I make it work? Thanks for any advice.

bildschirmfoto 2017-10-06 um 15 55 23

Edit:
Tried out reinstalling requests with pip for version 3.5 without succeeding.
Tried reinstalling urllib3 and utils with pip for version 3.5 without succeeding.

JKEbe 2017-10-9
11

@rrahir urllib3 不兼容的 python 2, 请您检查备选方案

原文:

@rrahir urllib3 not compatible python 2, can you check alternative plz

dmoodoo 2017-10-9
12

使用6f6f3a4修复。

原文:

Fixed with 6f6f3a4.

返回
发表文章
vimit
文章数
1
评论数
2
注册排名
60789