发表文章

[PHP] 安装问题 install problem[yii2-usuario]

whisere 2017-10-9 215

遵循以下说明: http://yii2-usuario.readthedocs.io/en/latest/
和作曲家需要2好友/yii2-usuario: 〜1。0
还可以尝试@dev并将稳定性更改为开发,

2好友/yii2-selectize-小部件36
仍报告相同的错误

抱歉意外张贴到 yii2-selectize-widget, 但它是相关的两个我想..。

原文:

followed the instruction here: http://yii2-usuario.readthedocs.io/en/latest/
and composer require 2amigos/yii2-usuario:~1.0
also try @dev and change stability to dev,

2amigos/yii2-selectize-widget#36
still reports the same error above

sorry accidentally posted to yii2-selectize-widget, but it is relevant to both I guess...

相关推荐
最新评论 (16)
tonydspaniard 2017-10-9
1

把它添加到你的作曲家, 告诉我它是如何:

"minimum-stability""dev",
"prefer-stable"true,
原文:

Add this to your composer and tell me how it goes:

"minimum-stability": "dev",
"prefer-stable": true,
whisere 2017-10-9
2

谢谢!我试过, 但它仍然报告相同:

问题1
-2 好友/yii2-usuario 1.0.0 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0. 0-测试版需要2好友/yii2-selectize-小部件〜 1.0-> 满足由2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.1 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.10 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.11 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.12 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.13 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.2 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.3 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.4 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.5 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.6 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.7 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.8 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-usuario 1.0.9 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0. x-dev]。
-2 好友/yii2-selectize-小部件 1.0. x-dev 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的包。
-2 好友/yii2-selectize-小部件1.0.3 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
-2 好友/yii2-selectize-小部件1.0.2 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
-2 好友/yii2-selectize-小部件1.0.1 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
-2 好友/yii2-selectize-小部件1.0.0 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
-2 好友/yii2-usuario 〜 1.0-> 满足由2好友/yii2-usuario [1.0. 0, 1.0. 0-β, 1.0.1, 1.0.10, 1.0.11, 1.0.12, 1.0.13, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9] 的安装要求。

潜在原因:

请阅读https://getcomposer.org/doc/articles/troubleshooting.md以了解进一步的常见问题。

原文:

Thank you! I have tried but it still reported the same:

Problem 1
- 2amigos/yii2-usuario 1.0.0 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.0-beta requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.1 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.10 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.11 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.12 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.13 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.2 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.3 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.4 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.5 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.6 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.7 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.8 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-usuario 1.0.9 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.x-dev].
- 2amigos/yii2-selectize-widget 1.0.x-dev requires bower-asset/selectize ~0.12.0 -> no matching package found.
- 2amigos/yii2-selectize-widget 1.0.3 requires bower-asset/selectize ~0.12.0 -> no matching package found.
- 2amigos/yii2-selectize-widget 1.0.2 requires bower-asset/selectize ~0.12.0 -> no matching package found.
- 2amigos/yii2-selectize-widget 1.0.1 requires bower-asset/selectize ~0.12.0 -> no matching package found.
- 2amigos/yii2-selectize-widget 1.0.0 requires bower-asset/selectize ~0.12.0 -> no matching package found.
- Installation request for 2amigos/yii2-usuario ~1.0 -> satisfiable by 2amigos/yii2-usuario[1.0.0, 1.0.0-beta, 1.0.1, 1.0.10, 1.0.11, 1.0.12, 1.0.13, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9].

Potential causes:

Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.

whisere 2017-10-9
3

需要鲍尔资产/selectize 〜 0.12.0-> 没有找到匹配的包。

不知道这是否是原因, 不能找到鲍尔资产/selectize 在 packagist?
https://packagist.org/search/?q=bower-asset%2Fselectize

原文:

requires bower-asset/selectize ~0.12.0 -> no matching package found.

Not sure if this is the cause, can't find bower-asset/selectize in packagist?
https://packagist.org/search/?q=bower-asset%2Fselectize

tonydspaniard 2017-10-9
4

@whisere我想我要修改这个小部件, 并使用我们最近的 select2。

原文:

@whisere I think I am going to modify that widget and use our recent select2.

whisere 2017-10-9
5

听起来不错, 谢谢!请让我知道当它准备使用。:)

原文:

That sounds great, thank you! Please let me know when it is ready to use. :)

sinfuljosh 2017-10-9
6

这与 yiisoft 从fxp 资产中移开并开始使用资产 packagist有什么关系?

试图充分理解这一点, 以及。:)

原文:

By any chance is this related to yiisoft moving away from fxp-asset and started using asset-packagist ?

Trying to fully understand this as well. :)

tonydspaniard 2017-10-9
7

@sinfuljosh否, 它没有任何可做的事。我相信是一个问题与 Selectize 本身

原文:

@sinfuljosh no, it has nothing to do. I believe is an issue with Selectize itself

sinfuljosh 2017-10-9
8

我想通了, 在某种程度上, 这是与我早先的评论。

当前版本的 Yii2 已删除 fxp/作曲家-资产插件的要求安装。许多安装 Yii2 的指南提到了下面的命令, 因为核心 Yii2 框架不再需要它。

composer global require "fxp/composer-asset-plugin:~1.3"

您的 selectize 小部件仍然依赖于上述软件包安装, 以加载鲍尔资产/selectize, 否则错误的出现在原来的帖子发生。

我做了你的 selectize 小部件的叉子与调整, 以利用资产 packagist. org 方法现在正在使用的 yiisoft, 这解决了问题。

https://github.com/sinfuljosh/yii2-selectize-widget

唯一的更改是作曲家. json

关于安装路径的更改, 在这里可以找到更多的信息https://asset-packagist.org/site/about有关两种解决此问题的方法, yiisoft 使用别名方法。

原文:

I figured it out, in a way it is related to my earlier comment.

The current versions of Yii2 have removed the requirement for fxp/composer-asset-plugin to be installed. Many of the guides for installing Yii2 mention the command below because it is no longer needed for the core Yii2 framework.

composer global require "fxp/composer-asset-plugin:~1.3"

Your selectize widget still depends on the above package to be installed to load the bower-asset/selectize, otherwise the error's seen in the original post occur.

I made a fork of your selectize widget with the adjustments to make use of the asset-packagist.org method now being used by yiisoft and this resolved the issue.

https://github.com/sinfuljosh/yii2-selectize-widget

The only change was to the composer.json

in regards to the change in the install path, more information can be found here https://asset-packagist.org/site/about about two methods to address this, yiisoft uses the alias method btw.

tonydspaniard 2017-10-9
9

感谢@sinfuljosh

原文:

Thanks @sinfuljosh

tonydspaniard 2017-10-9
10

更新 selectize

原文:

Updating selectize

whisere 2017-10-9
11

我尝试了相同的安装, 它仍然报告错误, 是否有其他的方式安装?或在此处进行任何更改: http://yii2-usuario.readthedocs.io/en/latest/
它似乎仍然使用鲍尔资产/selectize?

作曲家需要2好友/yii2-usuario: ~ 1。0

  • 2好友/yii2-usuario 1.0.9 需要2好友/yii2-selectize-小部件〜 1.0-> 满足2好友/yii2-selectize-小部件 [1.0. 0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0, 1.0. x-dev]。
    • 2好友/yii2-selectize-小部件 1.0. x-dev 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的包。
    • 2好友/yii2-selectize-小部件1.1.0 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
    • 2好友/yii2-selectize-小部件1.0.4 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
    • 2好友/yii2-selectize-小部件1.0.3 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
    • 2好友/yii2-selectize-小部件1.0.2 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
    • 2好友/yii2-selectize-小部件1.0.1 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
    • 2好友/yii2-selectize-小部件1.0.0 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。
    • 安装要求2好友/yii2-usuario 〜 1.0-> 满足由2好友/yii2-usuario [1.0. 0, 1.0. 0-β, 1.0.1, 1.0.10, 1.0.11, 1.0.12, 1.0.13, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9]。

作曲家.需要2好友/yii2-selectize-小部件: ~ 1。1
/作曲家. json 已更新
使用包信息加载作曲家资料库
更新依存关系 (包括需求开发)
无法将您的要求解析为可安装的软件包集。

问题1
-2 好友/yii2-selectize-小部件的安装要求〜 1.1-> 满足由2好友/yii2-selectize-小部件 [1.1. 0]。
-2 好友/yii2-selectize-小部件1.1.0 需要鲍尔-资产/selectize 〜 0.12.0-> 没有找到匹配的软件包。

原文:

I tried the same install, it still reported the error, is there other way to install? or any change here: http://yii2-usuario.readthedocs.io/en/latest/
it seems still using bower-asset/selectize ?

composer require 2amigos/yii2-usuario:~1.0

  • 2amigos/yii2-usuario 1.0.9 requires 2amigos/yii2-selectize-widget ~1.0 -> satisfiable by 2amigos/yii2-selectize-widget[1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.1.0, 1.0.x-dev].
    • 2amigos/yii2-selectize-widget 1.0.x-dev requires bower-asset/selectize ~0.12.0 -> no matching package found.
    • 2amigos/yii2-selectize-widget 1.1.0 requires bower-asset/selectize ~0.12.0 -> no matching package found.
    • 2amigos/yii2-selectize-widget 1.0.4 requires bower-asset/selectize ~0.12.0 -> no matching package found.
    • 2amigos/yii2-selectize-widget 1.0.3 requires bower-asset/selectize ~0.12.0 -> no matching package found.
    • 2amigos/yii2-selectize-widget 1.0.2 requires bower-asset/selectize ~0.12.0 -> no matching package found.
    • 2amigos/yii2-selectize-widget 1.0.1 requires bower-asset/selectize ~0.12.0 -> no matching package found.
    • 2amigos/yii2-selectize-widget 1.0.0 requires bower-asset/selectize ~0.12.0 -> no matching package found.
    • Installation request for 2amigos/yii2-usuario ~1.0 -> satisfiable by 2amigos/yii2-usuario[1.0.0, 1.0.0-beta, 1.0.1, 1.0.10, 1.0.11, 1.0.12, 1.0.13, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9].

composer. require 2amigos/yii2-selectize-widget:~1.1
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for 2amigos/yii2-selectize-widget ~1.1 -> satisfiable by 2amigos/yii2-selectize-widget[1.1.0].
- 2amigos/yii2-selectize-widget 1.1.0 requires bower-asset/selectize ~0.12.0 -> no matching package found.

whisere 2017-10-9
12

好吧需要把这个添加到作曲家. json 文件在我的项目下面:

"repositories": [
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        }
    ],

它在增加这之后工作。
谢谢!

原文:

Okay need to add this to the composer.json file under my project too:

"repositories": [
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        }
    ],

It worked after adding this.
Thanks!

tonydspaniard 2017-10-9
13

@whisere是模块作曲家还是项目的作曲家?

原文:

@whisere is that on module composer or your project's composer?

whisere 2017-10-9
14

我把它添加到我的项目作曲家, 但我怀疑它可能会在模块作曲家的工作。

原文:

I added it under my project composer but I suspect it might work too under the module composer.

tonydspaniard 2017-10-9
15

@whisere

我把它添加到我的项目作曲家, 但我怀疑它可能会在模块作曲家的工作。

我相信, 对于这个项目是需要设置如果你没有。它不适用于扩展 (小部件或模块), 因为它不覆盖父级。我们在日常工作中使用扩展, 没有问题。

感谢您的反馈和使用本模块。

原文:

@whisere

I added it under my project composer but I suspect it might work too under the module composer.

I believe that for the project is required that setting if you have not. It doesn't apply to extensions (widgets or modules) as it does not override the parent's. We use our extensions on our everyday work and no issues.

Thank you for your feedback and for using this module.

whisere 2017-10-9
16

谢谢你的帮助:)

原文:

Thank you for all your help :)

返回
发表文章
whisere
文章数
1
评论数
7
注册排名
60612