I figured it out, in a way it is related to my earlier comment.
The current versions of Yii2 have removed the requirement for fxp/composer-asset-plugin to be installed. Many of the guides for installing Yii2 mention the command below because it is no longer needed for the core Yii2 framework.
composer global require "fxp/composer-asset-plugin:~1.3"
Your selectize widget still depends on the above package to be installed to load the bower-asset/selectize, otherwise the error's seen in the original post occur.
I made a fork of your selectize widget with the adjustments to make use of the asset-packagist.org method now being used by yiisoft and this resolved the issue.
composer. require 2amigos/yii2-selectize-widget:~1.1
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.
- Installation request for 2amigos/yii2-selectize-widget ~1.1 -> satisfiable by 2amigos/yii2-selectize-widget[1.1.0].
- 2amigos/yii2-selectize-widget 1.1.0 requires bower-asset/selectize ~0.12.0 -> no matching package found.
I added it under my project composer but I suspect it might work too under the module composer.
I believe that for the project is required that setting if you have not. It doesn't apply to extensions (widgets or modules) as it does not override the parent's. We use our extensions on our everyday work and no issues.
Thank you for your feedback and for using this module.