发表文章

[PHP] 不会在论坛中显示主题如果 mangosweb 不在根目录中 "wont show topics in forum if mangosweb isnt in root directory"[mwenhanced]

GoogleCodeExporter 6月前 59

What steps will reproduce the problem?

1. Put the mangos website in a folder other then your root directory ex:
->ht docs(root directory)->mangosweb (folder).
2. Create a topic in the forums from the admin panel
3. Try to view your new topic

What is the expected output? What do you see instead?

The expected output is to be able to see the post. But what you really get
is a blank page. It try's to redirect to:

"./index.php?n=forum&sub=viewtopic&tid=(topic #)" 

when it should redirect to:

"./mangosweb/index.php?n=forum&sub=viewtopic&tid=(topic #)"


Please use labels and text to provide additional information.

wilson.steven10@gmail.com 2010年2月17日在 7:12 code.google.com 报告的原始问题

原文:
What steps will reproduce the problem?

1. Put the mangos website in a folder other then your root directory ex:
->ht docs(root directory)->mangosweb (folder).
2. Create a topic in the forums from the admin panel
3. Try to view your new topic

What is the expected output? What do you see instead?

The expected output is to be able to see the post. But what you really get
is a blank page. It try's to redirect to:

"./index.php?n=forum&sub=viewtopic&tid=(topic #)" 

when it should redirect to:

"./mangosweb/index.php?n=forum&sub=viewtopic&tid=(topic #)"


Please use labels and text to provide additional information.

Original issue reported on code.google.com by wilson.steven10@gmail.com on 17 Feb 2010 at 7:12

相关推荐
最新评论 (2)
GoogleCodeExporter 6月前
1
Open your /config/config.xml, then look for something like this at the end:

    <temp>
        <site_href>/</site_href>
        <site_domain>127.0.0.1</site_domain>
        <email_href>127.0.0.1</email_href>
        <base_href>http://127.0.0.1/</base_href>
    </temp>

change that to this

    <temp>
        <site_href></site_href>
        <site_domain></site_domain>
        <email_href></email_href>
        <base_href></base_href>
    </temp>

ionstorm662010年2月17日在七点半的原始评论

原文:
Open your /config/config.xml, then look for something like this at the end:

    <temp>
        <site_href>/</site_href>
        <site_domain>127.0.0.1</site_domain>
        <email_href>127.0.0.1</email_href>
        <base_href>http://127.0.0.1/</base_href>
    </temp>

change that to this

    <temp>
        <site_href></site_href>
        <site_domain></site_domain>
        <email_href></email_href>
        <base_href></base_href>
    </temp>

Original comment by ionstorm66 on 17 Feb 2010 at 7:30

GoogleCodeExporter 6月前
2
Wow i should have known that :DOH!: great work my friend!

最初的评论 wilson.steven10@gmail.com 在2010年2月17日在7:38

  • 更改的状态:固定
原文:
Wow i should have known that :DOH!: great work my friend!

Original comment by wilson.steven10@gmail.com on 17 Feb 2010 at 7:38

  • Changed state: Fixed
返回
发表文章
GoogleCodeExporter
文章数
3257
评论数
13138
注册排名
7388