发表文章

[Shell] 运行泊坞版本4.0 问题 Problem running docker version 4.0[homebridge-docker]

milanmitosinka 2017-10-9 79

你好,

我运行泊坞窗版本4.0 有问题。
screenshot
我有一个旧的 "最新", 这是工作的罚款, 所有刚刚开始。
如果我想开始4.0 包与相同的设置和相同的插件, 而不是旧的一个。

在泊坞窗的图像部分中, 我有以下内容:
一个集装箱与最新-这一个为我工作 (782 MB)
一个容器与 3.1-这一个在1分钟以后停止 (784 MB)
一个容器与 4.0-这在 1 min. (1 GB) 以后停止

你有什么线索吗?
我相信我需要使用一些新的版本, 由于 iOS 11, 因为目前的版本是无法到达我的手机。

有什么提示吗?安装. sh 和目录位置有什么区别吗?看我的3.0 工作正常。
我只有3插件。

我在日志中发现:
这与 npm 无法找到文件有关。问: 这在3.0 和3.1 或4.0 之间有变化吗?
和结束错误: 错误: 所请求的平台 "鸟巢" 没有被任何插件注册。

screenshot

谢谢!

米兰

原文:

Hello,

I have problem running docker version 4.0.
screenshot
I have one old "latest" which is working fine and all just start.
If I want to start 4.0 package with same settings and same plugins and all instead of older one.

In image section of docker I have this:
one container with latest - this one works for me (782 MB)
one container with 3.1 - this one stops after 1 min.(784 MB)
one container with 4.0 - this stops after 1 min. (1 GB)

do you have hint why ?
I believe I need to use some new version due to iOS 11 coz current version is not reachable on my phone.

Any hints ? Is there any difference between install.sh and directory location ? See mine. 3.0 works fine.
I have just 3 plugins.

I found in the log this:
This is related to npm not being able to find a file. Q: was there change in this between 3.0 and 3.1 or 4.0 ?
and end error: Error: The requested platform 'Nest' was not registered by any plugin.

screenshot

thank you !

Milan

相关推荐
最新评论 (6)
marcoraddatz 2017-10-9
1

因为版本2.1 没有对 install.sh 进行任何重大更改, 所以所有的都应该是好的。一分钟停止似乎是巢或另一个插件不能正常工作, 崩溃 Homebridge。我想你目前的容器是版本2.1 或 2.0.x, 其中 Homebrige < 0.4.16 是预装。较新的版本执行自动的 Homebridge, 因此嵌套版本可能与更新不兼容。

原文:

Since version 2.1 there's not been any major changes to the install.sh, so all should be fine. The one minute stop seems to be Nest or another plugin not working correctly and crashing Homebridge. I guess your current container was version 2.1 or 2.0.x, where Homebrige < 0.4.16 was pre-installed. The newer version do an auto-update of Homebridge, so the Nest version might be incompatible with an update.

milanmitosinka 2017-10-9
2
原文:
milanmitosinka 2017-10-9
3
marcoraddatz 2017-10-9
4

抱歉地说: 但是, 是的, 我认为其他插件也不能正常工作。此错误是由 homebridge-tahoma 引发的。

原文:

Sorry to say: But yes, I think the other plugins are also not working correctly. This error was thrown by homebridge-tahoma.

milanmitosinka 2017-10-9
5
原文:
marcoraddatz 2017-10-9
6

也许插件已经改变配置或不兼容最新的 Homebridge。此容器 (v4.0) 与 iOS 11 兼容, 只要使用的 Homebridge 版本是最新的。

顺便说一下, 你不需要把插件放到文件夹里, 只要你不开发自己的插件就可以了。尝试通过 install.sh : https://github.com/marcoraddatz/homebridge-docker/blob/master/samples/install.sh

原文:

Maybe the plugins have changed configs or aren't compatible with newest Homebridge. This container (v4.0) is compatible with iOS 11, as long as the used Homebridge version is up to date.

Btw. you don't need to put the plugins into the folder, as long as you're not developing your own plugin. Try to install them via install.sh: https://github.com/marcoraddatz/homebridge-docker/blob/master/samples/install.sh

返回
发表文章
milanmitosinka
文章数
1
评论数
3
注册排名
60632