发表文章

[Shell] 清单列表条目中的 linux/amd64 没有匹配的清单 no matching manifest for linux/amd64 in the manifest list entries[wordpress]

huegelc 2017-10-9 710

尝试使用 docker compose up -d

# Dockerfile with SSL activated

FROM wordpress
ENV DEBIAN_FRONTEND noninteractive

RUN apt-get update && \
    apt-get dist-upgrade -y  --no-install-recommends -o Dpkg::Options::="--force-confold"   && \
    apt-get install -y  --no-install-recommends ssl-cert apt-utils && \
    rm -r /var/lib/apt/lists/* && \
    a2enmod ssl && \
    a2ensite default-ssl

COPY ./tests/test.sh /test.sh
RUN chmod 755 /test.sh

EXPOSE 80
EXPOSE 443
ENV DEBIAN_FRONTEND teletype

docker pull wordpress 并获取:

latest: Pulling from library/wordpress
no matching manifest for linux/amd64 in the manifest list entries
原文:

Trying to pull latest image either with docker compose up -d and

# Dockerfile with SSL activated

FROM wordpress
ENV DEBIAN_FRONTEND noninteractive

RUN apt-get update && \
    apt-get dist-upgrade -y  --no-install-recommends -o Dpkg::Options::="--force-confold"   && \
    apt-get install -y  --no-install-recommends ssl-cert apt-utils && \
    rm -r /var/lib/apt/lists/* && \
    a2enmod ssl && \
    a2ensite default-ssl

COPY ./tests/test.sh /test.sh
RUN chmod 755 /test.sh

EXPOSE 80
EXPOSE 443
ENV DEBIAN_FRONTEND teletype

or docker pull wordpressand get:

latest: Pulling from library/wordpress
no matching manifest for linux/amd64 in the manifest list entries
相关推荐
最新评论 (5)
qmachard 2017-10-9
1

您好@huegelc, 我有同样的问题, 如果我很容易地修复它, 我说你!

原文:

Hi @huegelc, I have the same problem, if I fix it easily I say you !

tianon 2017-10-9
2
tianon 2017-10-9
3

此外, "泊坞窗-库/oi-janky-groovy@b639001 将在将来帮助解决此问题。

原文:

Also, docker-library/oi-janky-groovy@b639001 which should help with this problem in the future.

tianon 2017-10-9
4

我也去了, 并触发了一个版本的 amd64/wordpress 现在。

原文:

I've also gone and triggered a build of amd64/wordpress right now.

huegelc 2017-10-9
5

可以确认它再次工作

原文:

can confirm it works again

返回
发表文章
huegelc
文章数
1
评论数
1
注册排名
60629