发表文章

[Java] 加载专用的服务器客户端代码时崩溃? Crash when loading on a dedicated server- clientside code?[Back-to-Eco]

ProsperCraft 2017-10-9 33

由: java.lang.NoClassDefFoundError: 网/minecraftforge/客户/型号/ModelLoader

https://gist.github.com/ProsperCraft/0878c6e63ec141a5baaf62ef68f6275e

当您尝试在服务器上运行它时, 这是否试图加载客户端代码?

原文:

Caused by: java.lang.NoClassDefFoundError: net/minecraftforge/client/model/ModelLoader

https://gist.github.com/ProsperCraft/0878c6e63ec141a5baaf62ef68f6275e

Is this trying to load clientside code when you try to run it on a server?

相关推荐
最新评论 (12)
ProsperCraft 2017-10-9
1

首先... 顺便:)

原文:

First...by the way :)

Tebreca 2017-10-9
2

看起来像 modelloader 类没有找到, 尝试和 reïnstall, 如果它仍然不工作生病尝试和修复它在下一个版本

原文:

looks like the modelloader class is not found, try and reïnstall, if it still doesnt work ill try and fix it in the next version

Tebreca 2017-10-9
3

我很抱歉, 试着安装一个新版本的伪造... 你的版本已经过时, 然后 mods 的加载不会工作, 或旧版本。

原文:

ow im sorry, try and install a newer version of forge... your version is outdated and then the mods loading wont work, or a older version.

ProsperCraft 2017-10-9
4

伪造版本2469是昨天发布的, 是从他们的网站, 我刚才下载的最新的下载是过时的?

原文:

The forge version 2469 that was released yesterday and is the latest download from their site that I just downloaded moments ago is outdated?

Tebreca 2017-10-9
5

你需要锻造-1.12-14.21.1. 2387 至少;

原文:

you need to have forge-1.12-14.21.1.2387 at least ;-)

Tebreca 2017-10-9
6

不那么你会需要安装一个旧的, 我猜

原文:

nope then you will meed to install a older one i guess

ProsperCraft 2017-10-9
7

2469是一个更高的数字, 最近的 2387, 看起来您需要更新;)

原文:

2469 is a higher number, and more recent then 2387, looks like you need updating ;)

Tebreca 2017-10-9
8

是的, 这将是所有在 bte 1.0。0

原文:

yeah, that will be all in bte 1.0.0

Tebreca 2017-10-9
9

我没有时间更新, 因为生病需要重写整个国防部, 因为 minecraftforge 更新。

原文:

i dont have time to update because ill need to rewrite the whole mod because of minecraftforge updates.

ProsperCraft 2017-10-9
10

这是交易, 它在客户中很管用。

这是非常常见的新的 mods, 我不知道到底是怎么做的, 但你需要有一个服务器版本的 jar, 不调用客户端代码。

也许这会有帮助- https://mcforge.readthedocs.io/en/latest/concepts/sides/

原文:

Here is the deal, it works fine in the client.

This is very common with new mods, I don't know exactly how it is done, but you need to have a server version in the jar that doesn't call clientside code.

Perhaps this will help- https://mcforge.readthedocs.io/en/latest/concepts/sides/

Tebreca 2017-10-9
11

2387是推荐版本的 mcforge, 所以尝试和安装一个, 当生病弄清楚如何渲染模型在最新版本。

原文:

2387 is a recommended version of mcforge so try and install that one when ill figure out how to render models in the newest version.

Tebreca 2017-10-9
12

我得到了 sidedproxy 问题固定, 所以生病创建一个修复版本

原文:

ive got the sidedproxy problem fixed so ill create a fix release

返回
发表文章
ProsperCraft
文章数
8
评论数
15
注册排名
13536