发表文章

[Ruby] 发布5.1。0 Release 5.1.0[mongoid-geospatial]

ryush00 2017-10-9 41

我发现rubygems.org mongoid-地理空间卡在5.0.0 上。我认为应该更新到新版本。谢谢.

原文:

I found out rubygems.org mongoid-geospatial is stuck on 5.0.0. I think It should be updated to newer version. thanks.

相关推荐
最新评论 (11)
dblock 2017-10-9
1

5.1.0 似乎没有根据https://github.com/mongoid/mongoid-geospatial/blob/master/CHANGELOG.md进行任何更改, 或者我遗漏了什么?

原文:

5.1.0 doesn't seem to have have any changes according to https://github.com/mongoid/mongoid-geospatial/blob/master/CHANGELOG.md, or am I missing something?

ryush00 2017-10-9
2

嗯。我只想用这个宝石与 mongoid 6。但我有个错误

mongoid 6 还不支持吗?

原文:

Hmm.. I just want to use this gem with mongoid 6. But I got an error.

Is it not support mongoid 6 yet?

dblock 2017-10-9
3

AFAIK 5.0.0 应正确使用 Mongoid 6, 错误是什么?使用头会消失吗?

原文:

AFAIK 5.0.0 should work correctly with Mongoid 6, what's the error? Does it go away with using HEAD?

ryush00 2017-10-9
4

我这样做的头, 它也不使用 NameError: uninitialized constant Mongoid::Geospatial 错误。

我使用 rails 5.1.3 和 mongoid 6.2.0。

原文:

I did that with HEAD and it also not working with NameError: uninitialized constant Mongoid::Geospatial error.

I'm using rails 5.1.3 and mongoid 6.2.0.

dblock 2017-10-9
5

这听起来很奇怪, 添加显式 require 'mongoid/geospacial' 解决问题了吗?

原文:

That sounds odd, does adding an explicit require 'mongoid/geospacial' fix the problem?

ryush00 2017-10-9
6

require 'mongoid/geospacial'Gemfile?

原文:

require 'mongoid/geospacial' to Gemfile?

dblock 2017-10-9
7

不在你的代码里在某个类似于 config/initializers 的 rails 应用程序中。

我假设您添加了 gem 'geospacial' Gemfile 并运行 bundle install , 然后重新启动了 Rails。

原文:

No, in your code. In a rails app somewhere like in config/initializers.

I assume you added gem 'geospacial' to Gemfile and ran bundle install, then restarted Rails.

ryush00 2017-10-9
8
ryush00@dev:~/app$ bundle
...
Using mongoid 6.2.0
...
Using mongoid-geospatial 5.0.0 from https://github.com/mongoid/mongoid-geospatial.git (at master@9d25a5a)
...
Using rails 5.1.3
...
Bundle complete! 24 Gemfile dependencies, 96 gems now installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.
The latest bundler is 1.15.3, but you are currently running 1.15.1.
To update, run `gem install bundler`

ryush00@dev:~/app$ rails s
/home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:292:in `require': cannot load such file -- mongoid/geospacial (LoadError)
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:292:in `block in require'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:258:in `load_dependency'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:292:in `require'
        from /home/ryush00/app/config/application.rb:18:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:129:in `require'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:129:in `block in perform'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:126:in `tap'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:126:in `perform'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/thor-0.19.4/lib/thor/command.rb:27:in `run'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/thor-0.19.4/lib/thor/invocation.rb:126:in `invoke_command'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/thor-0.19.4/lib/thor.rb:369:in `dispatch'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/command/base.rb:63:in `perform'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/command.rb:44:in `invoke'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands.rb:16:in `<top (required)>'
        from /home/ryush00/app/bin/rails:9:in `require'
        from /home/ryush00/app/bin/rails:9:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `load'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `call'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client/command.rb:7:in `call'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client.rb:30:in `run'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/bin/spring:49:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `load'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
        from /home/ryush00/app/bin/spring:15:in `<top (required)>'
        from bin/rails:3:in `load'
        from bin/rails:3:in `<main>'

真奇怪。

我将找到另一种使用地理空间的方法。谢谢.

原文:
ryush00@dev:~/app$ bundle
...
Using mongoid 6.2.0
...
Using mongoid-geospatial 5.0.0 from https://github.com/mongoid/mongoid-geospatial.git (at master@9d25a5a)
...
Using rails 5.1.3
...
Bundle complete! 24 Gemfile dependencies, 96 gems now installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.
The latest bundler is 1.15.3, but you are currently running 1.15.1.
To update, run `gem install bundler`

ryush00@dev:~/app$ rails s
/home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:292:in `require': cannot load such file -- mongoid/geospacial (LoadError)
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:292:in `block in require'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:258:in `load_dependency'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/activesupport-5.1.3/lib/active_support/dependencies.rb:292:in `require'
        from /home/ryush00/app/config/application.rb:18:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:129:in `require'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:129:in `block in perform'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:126:in `tap'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands/server/server_command.rb:126:in `perform'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/thor-0.19.4/lib/thor/command.rb:27:in `run'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/thor-0.19.4/lib/thor/invocation.rb:126:in `invoke_command'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/thor-0.19.4/lib/thor.rb:369:in `dispatch'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/command/base.rb:63:in `perform'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/command.rb:44:in `invoke'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/railties-5.1.3/lib/rails/commands.rb:16:in `<top (required)>'
        from /home/ryush00/app/bin/rails:9:in `require'
        from /home/ryush00/app/bin/rails:9:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `load'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `call'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client/command.rb:7:in `call'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/client.rb:30:in `run'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/bin/spring:49:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `load'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `<top (required)>'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
        from /home/ryush00/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
        from /home/ryush00/app/bin/spring:15:in `<top (required)>'
        from bin/rails:3:in `load'
        from bin/rails:3:in `<main>'

It's really odd..

I'm going to find another way to use geospatial. Thanks.

dblock 2017-10-9
9

@ryush00你能在 Github 上提出一个简单的 Rails 项目来重现问题吗?

原文:

@ryush00 Can you put up a plain Rails project with this on Github that reproduces the problem?

dblock 2017-10-9
10

哦, 你拼写 geospatial , 它是一个 t

原文:

Oh you mispelled geospatial, it's with a t.

ryush00 2017-10-9
11

哦!谢谢。不。
我的错误

原文:

Oh! Thank you. lol
My mistake

返回
发表文章
ryush00
文章数
1
评论数
7
注册排名
60719